Jump to content


Photo

Uninstall add-ons completely how to

re-install add-ons

  • Please log in to reply
15 replies to this topic

#1 Rono

Rono

    Advanced Member

  • Members
  • PipPipPip
  • 155 posts
  • LocationWolli Creek, NSW,

Posted 01 January 2015 - 11:02 AM

Dear Dr Dean

I want to completely uninstall certain sophisticated aircraft and re-install them all over again.

The default in-house MS uninstaller (W7), though apparently removing the add-on, doesn't. Re-installing shows that the pesky details are still there. The problem still remains.

 

As a simple evidence of this is that on re-installation I am not asked for the registration / keycode of the programme. And there are still bits and pieces floating e.g. in C:users\myname\applicationa datat\roaming\Microsoft\FSX\simobjects\airplanes> name of aircraft and the add-on is still there.

 

A Google for a solution to the problem produces several uninstall programmes as options. They may be 'safe' but I am scared to run them

 

What uninstall programme do you use?

Rono



#2 Gartro

Gartro

    Advanced Member

  • Members
  • PipPipPip
  • 1,131 posts

Posted 01 January 2015 - 07:27 PM

Rono

 

Pending hearing from Dean with the answer, I am assuming from your recent posts that the iFly 737NG may be one of them. Did you use the uninstaller which comes with that product?

 

Gary



#3 m0dpsych

m0dpsych

    Advanced Member

  • Members
  • PipPipPip
  • 161 posts
  • LocationBrisbane, Queensland

Posted 01 January 2015 - 09:59 PM

Hi Rono,

 

I concur with Gary. I have that particular aircraft. To remove it completely go to Start - All Programs - scroll down until you find "IFly Jets-The 737NG for FSX" - left click on title - you should then see an option called "Uninstall IFly Jets ......left click on that and follow the instructions. Once removed I usually reboot my machine and then defrag my drive. I usually only do the Windows uninstaller if it says to in any manuals, otherwise I do it this way.

 

When I reinstalled mine it didn't ask for a registration key either. Maybe somehow FSX remembers it?

 

The other Gary


I'm from the Government and I'm here to help!!!!


#4 Rono

Rono

    Advanced Member

  • Members
  • PipPipPip
  • 155 posts
  • LocationWolli Creek, NSW,

Posted 02 January 2015 - 12:03 PM

Gentlemen, very discerning of you to immediately jump to my problem with the iFly.

 

Right, that was the major problem needing a complete cleansing of the programme. I did just what you suggested but the same problem re-appeared 'Can't load iFly 737NG.dll.'

Actually with Alt-Tab I can (as before) get the B737 in the air, but without the Add-on menu facility. That means the panel settings and route are not saved.

 

But co-incidental to that, I went back to my loyal Wilco 737 which would now not auto-start, nor would the panel above 'work'. Both of these progs (Wilco and iFly)operated without problems before I made a complete uninstallation,/ re-installation of the whole programme and FSX.

 

And while your thinking further, my other problem: no panel on most aircraft when on 2D, I still cannot find a solution. A contributing factor may be that I have a 3-screen setup, but even when reduced to an smaller settin the problems still remains

 

Thank you for your interest.

 

Rono



#5 Gartro

Gartro

    Advanced Member

  • Members
  • PipPipPip
  • 1,131 posts

Posted 02 January 2015 - 03:33 PM

Rono

 

In the absence of both Dean and a locum in his stead, I Googled your message  'Can't load iFly 737NG.dll.'

 

A number of the entries for that term take you to the iFly forum.

 

I could not take the chase any further because you need to be registered to access the Support segment, I can't remember if I am (and what my username etc is) and I would have to track down my purchase details (via the PCA Aust website) if I am not registered.

 

If you are registered for the iFly forum or have your purchase details handy to enable you to get registered, it might be worthwhile trying there.

 

Gary



#6 Rono

Rono

    Advanced Member

  • Members
  • PipPipPip
  • 155 posts
  • LocationWolli Creek, NSW,

Posted 02 January 2015 - 09:44 PM

Gary

Thank you, I will give that a go. I actually have four sets of names/passwords for that supplier, all before 2011 (when I changed all purchases to PCAA). The supplier  cut me off after 5 tries but  it invited me to return in 15 minutes. But it may not be until tomorrow. I will keep the forum informed. 

Rono



#7 m0dpsych

m0dpsych

    Advanced Member

  • Members
  • PipPipPip
  • 161 posts
  • LocationBrisbane, Queensland

Posted 06 January 2015 - 05:18 PM

Hi Rono,

Couple of thoughts regarding your problem.
Did you uninstall FSX as well?
If so was it using Windows uninstall?
Do you have Accelerator pack (gold edition) installed?

I'm from the Government and I'm here to help!!!!


#8 m0dpsych

m0dpsych

    Advanced Member

  • Members
  • PipPipPip
  • 161 posts
  • LocationBrisbane, Queensland

Posted 06 January 2015 - 05:18 PM

Hi Rono,

Couple of thoughts regarding your problem.
Did you uninstall FSX as well as Add ons?
If so was it using Windows uninstall?
Do you have Accelerator pack (gold edition) installed?
The reason I ask is if you have accelerator installed you need to delete that as well as the standard FSX uninstall to remove everything. That could be another reason you are having problems with IFly. Also when I uninstall I format my FSX drive (separate to windows). Do you have it on a separate drive to Windows (which is a safer option)

Also there are 2 updates on the IFly forum, I am trying to find out more about them.

If I have confused you to much feel free to drop me a pm.

Regards

Gary

I'm from the Government and I'm here to help!!!!


#9 Dean (PC Aviator)

Dean (PC Aviator)

    Administrator, PC Aviator Manager

  • Administrators
  • 2,641 posts
  • LocationBrisbane, Queensland

Posted 07 January 2015 - 06:41 PM

Hi all,

 

These problems often open up a huge can of worms. There is no one solution that works for everything, so ultimately, some of these things need to be worked on a case-by-case basis, and usually it is best to consult the developer's forum for the product you are having trouble with, as these guys made it, and hence should know how best to fix any issues with it. I will say one thing though, stay away from software that claims to "uninstall" things better than the rest, or dedicated software cleaner apps. Most often they create more problems than they solve.


pcaemailsmall.jpg

Dean Bielanowski

Manager - PC Aviator Australia
The Flight Simulation Company!
Retailing Sim DVD Software, Downloads, Hardware and Accessories
We ship worldwide with FAST dispatch!
Online Store: http://www.pcaviator.com.au/store
[Facebook] [Twitter] [Blog] [Scoop.it] [YouTube] [Google+]

 


#10 Rono

Rono

    Advanced Member

  • Members
  • PipPipPip
  • 155 posts
  • LocationWolli Creek, NSW,

Posted 07 January 2015 - 10:53 PM

Gentlemen

 

Thank you. I 'did' it all. I consulted AVSIM forums and the iFly. The last entry on AVSIM on my 2D panel blackout and shivery pointer, was  5 years ago.  There was no solution  that worked with the enquirer (or me) I  (thank you Gary) searched the iFly forums, and could not enter because I had a boxed editions from whom I do not know (pre PCAA). I could get for free, their instructions for re-installing. Did not work.

 

Yes I un-installed the  FSX using the Windows facility. I have it on the C: with MS Office (non other) because my C: is solid state. It is fast. I have the Accelerator Pack solely for the SP! and SP2. .

 

To be positive everything-out does enable me to remove the flotsam from my overloaded  hangar. I am an impulse purchaser. That is another reason why I now buy only from  PCAA.

 

Rono



#11 Rono

Rono

    Advanced Member

  • Members
  • PipPipPip
  • 155 posts
  • LocationWolli Creek, NSW,

Posted 14 January 2015 - 02:14 PM

Gooday Doctor Deane and friends

 

Further consideration please: the panel blackout in 2d and the inability of aircraft to start with Control E.(that is a new problem that I had not mentioned). The jets all open with cold-and dark.

 

I now have a new setup. Meticulously, meticulously,  following instructions in http:support.precisionmanuals.com/kb/a87/how-to-uninstall-and-reinstall-fsx.aspx. I have (in theory) a squeaky clean FSX. Even, as the instructions, and as given by Doctor Deane some time ago, I re-installed it all in C:\FSX. That fixed the dll.xml problem with iFly and all aircraft ascends at  the appropriate rate.  

 

Your further help would be appreciated.

Rono

 

PS My son an ITC in a specialised area and  who earns frequent flyer points with Virgin and Rex echoed Dean's advice. He threatens to disown me if I used an external uninstall programme.



#12 Dean (PC Aviator)

Dean (PC Aviator)

    Administrator, PC Aviator Manager

  • Administrators
  • 2,641 posts
  • LocationBrisbane, Queensland

Posted 14 January 2015 - 11:01 PM

Ron,

 

So you reinstalled FSX from scratch? And now you still have those issues with 2D panels being black, even on every default aircraft?

If this is the case, it *may* have something to do with your video card (that would be my first guess). What video card do you have and have you updated the card drivers recently?


pcaemailsmall.jpg

Dean Bielanowski

Manager - PC Aviator Australia
The Flight Simulation Company!
Retailing Sim DVD Software, Downloads, Hardware and Accessories
We ship worldwide with FAST dispatch!
Online Store: http://www.pcaviator.com.au/store
[Facebook] [Twitter] [Blog] [Scoop.it] [YouTube] [Google+]

 


#13 Rono

Rono

    Advanced Member

  • Members
  • PipPipPip
  • 155 posts
  • LocationWolli Creek, NSW,

Posted 20 January 2015 - 05:35 PM

Dean

 

Thank you for your reply and forgive my slowness  in reading all the entries in your forum

I am not sure what is a 'video driver'. Where do I find it?

I looked under Device Manager in Control Panel.

Maybe it is AMD RadeoHD 7900 series.

Or what else do I look for?

 

Ron



#14 Dean (PC Aviator)

Dean (PC Aviator)

    Administrator, PC Aviator Manager

  • Administrators
  • 2,641 posts
  • LocationBrisbane, Queensland

Posted 21 January 2015 - 04:39 PM

A video card driver is basically the software interface for the hardware. Usually new video card drivers are released fairly often to make your video card compatible with more software and games, or to improve the performance of your card. If you have the AMD RadeonHD 7900 listed in your device manager, chances are this is the video card installed on your system. You can download and install new drivers for your video card from the following page: http://support.amd.com/en-us/download

 

I won't claim this will fix the problem, but it is generally always a good idea to have the latest driver set installed for your video card. If you have never updated them, or used drivers that came off the included disk in the video card box, chances are the drivers could be years old!


pcaemailsmall.jpg

Dean Bielanowski

Manager - PC Aviator Australia
The Flight Simulation Company!
Retailing Sim DVD Software, Downloads, Hardware and Accessories
We ship worldwide with FAST dispatch!
Online Store: http://www.pcaviator.com.au/store
[Facebook] [Twitter] [Blog] [Scoop.it] [YouTube] [Google+]

 


#15 Rono

Rono

    Advanced Member

  • Members
  • PipPipPip
  • 155 posts
  • LocationWolli Creek, NSW,

Posted 27 January 2015 - 08:57 PM

Gooday

 

I have completely uninstalled / re-installed FSX. Why? I presented my several problems in two or more entries in the forums. Having cleared-out the whole of FSX setting it in different directories  i.e. C:\FSX and the c:\FSSX and re-installing all the add-ons then in groups of 4 then testing them,. I found that what appeared to be a virus in a download which I saved on disk. That caused my disasters! I I also found that the black 2d half screen appeared only when I loaded fsx.sp2. I tested it - not until then.  Oddly the third time I installed the iFly 737 it was a self-starter; none of the start-up routine with the multiple of switches. Contributors to  AVSIM forum have ideas, but none of   them worked for them or me.  

 

Now why doesn't Control E work on some of the a/c?

 

Rono



#16 Dean (PC Aviator)

Dean (PC Aviator)

    Administrator, PC Aviator Manager

  • Administrators
  • 2,641 posts
  • LocationBrisbane, Queensland

Posted 29 January 2015 - 10:05 PM

Ron,

 

Ctrl+E not working... Which aircraft? Default or add-ons?


pcaemailsmall.jpg

Dean Bielanowski

Manager - PC Aviator Australia
The Flight Simulation Company!
Retailing Sim DVD Software, Downloads, Hardware and Accessories
We ship worldwide with FAST dispatch!
Online Store: http://www.pcaviator.com.au/store
[Facebook] [Twitter] [Blog] [Scoop.it] [YouTube] [Google+]

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users